Potential issue detected

Incident Report for Jitsu

Resolved

This incident has been resolved.
Posted Aug 16, 2026 - 12:41 PDT

Investigating

We have detected a potential issue with one of our services and our team is investigating.

Potential service affected: Recipient Tracking Page
Posted Aug 16, 2026 - 12:33 PDT