Potential issue detected

Incident Report for Jitsu

Resolved

This incident has been resolved.
Posted May 13, 2026 - 02:03 PDT

Investigating

We have detected a potential issue with one of our services and our team is investigating.

Potential service affected: Recipient Tracking Page
Posted May 13, 2026 - 02:01 PDT