EasyPost integration is not passing reference fields

Incident Report for Jitsu

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 17:17 PST

Investigating

Shipments submitted to us via EasyPost may not have their order reference fields populated, which could affect label barcodes and other printed identifiers.

Our partners at EasyPost are investigating.
Posted Jan 07, 2026 - 14:08 PST
This incident affected: Public API.