Potential issue detected

Incident Report for Jitsu

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 07:26 PST

Investigating

We have detected a potential issue with one of our services and our team is investigating.

Potential service affected: Driver App API
Posted Jan 09, 2026 - 07:19 PST