Potential issue detected

Incident Report for Jitsu

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 06:37 PDT

Update

Our team has confirmed an issue with one of our services and we are working to resolve.

Service affected: Recipient Tracking Page
Posted Jul 08, 2025 - 06:35 PDT

Investigating

We have detected a potential issue with one of our services and our team is investigating.

Potential service affected: Recipient Tracking Page
Posted Jul 08, 2025 - 06:35 PDT